1911 Forums : 1911Talk banner
1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I went to the range today to break in my warthog that I got a few weeks back. the first time I went to the range I put 25 or so rounds thru with out any problems. But then I went again today and put 90 rounds thru but it jammed frequently. It not only jammed but also a couple of times ejected the empty case and a live round at the same time. so if anyone could help me with this it would be great thanks guys in advance - Rob
 

·
Registered
Joined
·
2 Posts
The ejected live rounds sounds really strange. I would oil it well, and continure breaking it in before I would suspect any issues though.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
yeah thats what I thought. it happened like like 6 times when i was at the range. it made me kinda wounder
 

·
Registered
Joined
·
366 Posts
If it keeps it up after the break in period I would say ship it back, I had to send my LTC back in for a sight issue and the guys at para had it back in my hands in less than two weeks. I was thrilled with the customer service, and the fact that it got fixed right the first time.
 

·
Registered
Joined
·
9 Posts
Yeah the Para customer service is awesome. I only had jams when it wasn't lubed well. Small 1911s need lots of lube. Otherwise it is a great gun and accurate beyond belief. I used this gun solely for my LFI-1 class it is rocked. I shot the NH Police qualifier at 90% (only need 75% to qualify). While others shot a few percentage points better, they all shot full sized weapons. Great gun.
 
1 - 6 of 6 Posts
Top