1911 Forums : 1911Talk banner
1 - 5 of 5 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
I went out for practice earlier this week taking two of my 1911. My Gold Cup wouldn't lock the slide back on any of my mags, but there was no problems with the same mags in my Springfield. This is the first time I've had this issue. I finally had a chance to clean my pistols tonight and slid an empty mag in and pulled the slide back and the slide stop didn't engage.

I could use some suggestions on how to correct this
 

·
Premium Member
Joined
·
1,556 Posts
How bad is it worn where it catches the notch in the slide and on the inside where it gets caught by the mag follower...also what do your mag followers look like?

Pictures would help.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #3 ·
I'll take some pics tomorrow. I didn't think it was that worn.

The mag followers are the typical 7 round or the 47D wilson Combat followers
 

·
Premium Member
Joined
·
1,556 Posts
The mag followers are the typical 7 round or the 47D wilson Combat followers
Are they "notched" in the area where they push up on the slide stop?

And are you sure the slide stop isn't broke off on the inside?...it happens.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #5 ·
I'll check that tommorow when I get home. I thought about taking trying one of my other 1911's slide stops in it incase I have to order one from Midway.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top